Back to status overview

Delivery issues to Microsoft email addresses

Incident
Timeline
Start Tuesday February 24, 10:53 (on Feb 24, 2026)
End Monday March 2, 00:16 (yesterday)
Impact
No service impact expected.

We have received reports from several customers regarding “blacklisted” or “rate limited” error messages when sending emails to certain Microsoft-managed email addresses, primarily @hotmail.com accounts.

We have contacted Microsoft for clarification. At this time, Microsoft indicates that our mail servers are not blocked or rate limited. Based on this information, we believe the issue may be related to a temporary disruption or filtering problem within Microsoft’s infrastructure.

We have requested additional details and will continue to investigate. Further updates will be shared as soon as more information becomes available.

In the meantime, we recommend retrying delivery of rejected messages at a later time.

  • Resolved
    Resolved
    yesterday — Monday March 2, 00:16

    The incident has now been resolved. The last reported issues were observed on Thursday, February 29, 2026.

    We intentionally kept this notice open for a short period to ensure the issue was fully resolved and no further problems occurred.

    As the situation has remained stable, we are now closing this incident.

    Thank you for your patience and understanding.

  • Monitoring
    Monitoring
    5 days ago — Thursday February 26, 00:13

    Microsoft has now published a notice on their delisting page stating:

    “We are aware of an issue that may result in certain IP addresses being temporarily rejected at higher rates. We are actively investigating the issue. Please continue to submit tickets if you are experiencing this problem.”

    This confirms that the issue originates within Microsoft’s infrastructure and that they are actively working on a resolution.

    As a result, you may in some cases receive a “rate limit” error when sending emails to @outlook.com, @hotmail.com, or @live.nl addresses. This behavior is related to the issue acknowledged by Microsoft.

    As requested by Microsoft, we have submitted multiple reports and are currently awaiting further feedback.

    We fully understand that this situation is frustrating. Please rest assured that we are doing everything within our control to ensure the issue is resolved as quickly as possible. However, we remain dependent on Microsoft for the final resolution.

    We will share further updates here as soon as more information becomes available.

  • Monitoring
    Monitoring
    6 days ago — Wednesday February 25, 09:33

    We have identified that some customers are still receiving a “rate limiting” error from Microsoft when sending emails to Microsoft-managed addresses, such as @hotmail.com.

    We have forwarded these reports to Microsoft and requested further investigation. At this time, the scope of this issue appears to be more limited than the previously reported incident, but it is of course important that it is fully resolved.

    We will continue to monitor the situation and share further updates here as soon as more information becomes available.

  • Monitoring
    Monitoring
    6 days ago — Tuesday February 24, 22:57

    Microsoft has investigated the issue and informed us that a fix has been implemented on their side.

    Please note that it may take some time for this fix to be fully deployed across their entire platform. As a result, error messages may still occur intermittently over the coming hours.

    We will keep this incident open for now and continue to monitor the situation closely. Once we have confirmed that the issue has been fully resolved, we will provide a final update here and close this notice.

Last updated just now