Back to status overview

Incident Notice – Network connectivity issues

Incident
Timeline
Start Wednesday March 18, 09:58 (on Mar 18, 2026)
End Wednesday March 18, 12:07 (on Mar 18, 2026)
Impact
Some users may experience minor issues.

We are currently investigating an issue affecting connectivity from certain networks to our infrastructure, which may result in packet loss.

As a result, your website(s) or server(s) may be intermittently degraded or less reachable.

We are actively investigating and will keep you informed. A new update will be provided within 30 minutes at the latest.

  • Resolved
    Resolved
    on Mar 18, 2026 — Wednesday March 18, 12:07

    The issue has been resolved and was caused by an incident at the AMS-IX, a major internet exchange in the Netherlands.

    The packet loss we observed was the result of traffic being rerouted to alternative, available paths. In practice, this has caused little to no noticeable impact.

    Thank you for your patience and understanding.

  • Monitoring
    Monitoring
    on Mar 18, 2026 — Wednesday March 18, 10:17

    The situation appears to have stabilized.

    We will keep this incident open for the time being while the root cause is being investigated and to ensure the issue has been fully resolved.

Last updated just now